Hello There, Guest!  

My website https works, but http doesn't work


Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
 

dubois  

Junior Member


Posts: 4
Threads: 1
Joined: Jul 2017
Reputation: 0

#1
I am experiencing a weird problem with my site. In my country both https and http versions of my site works. I have set up a htaccess rule to redirect all http to https, to prevent duplicate content under the eye of search engines. In my computer everything works as expected. But my friend in another country said he cannot open http version of my site. He can open https normally. When open http, it is stuck and the browser scroll forever.

durand  

Junior Member


Posts: 14
Threads: 1
Joined: Jul 2017
Reputation: 0

#2
The browser is stuck at http, meaning that the request traffic hasn't reached the web server. Maybe that country filters out your domain and doens't want your domain to serve http traffic to them. What is the type con content of your website? Does it contain some kind of prohibited content in that country?

dubois  

Junior Member


Posts: 4
Threads: 1
Joined: Jul 2017
Reputation: 0

#3
Hi, thanks for your quick response. My domain doesn't contain any illegal content. It has only a few SEO articles I wrote myself. The funny thing is they do not block https. But I need http to work to redirect to https, otherwise I will lost a lot of traffic. I have just decided to shift my site from http to https a few days ago.

thomas  

Junior Member


Posts: 17
Threads: 0
Joined: Jul 2017
Reputation: 0

#4
Obviously your port 80 has been blocked somewhere. In the national level, I think if they filter out your domain, it is likely both port 443 (https) and port 80 (http) should be filtered out all together. There is a high chance that your hosting provider has block access from that country to your web server, and they "forgot" blocking port 443. It is best to contact your host to ask them

dubois  

Junior Member


Posts: 4
Threads: 1
Joined: Jul 2017
Reputation: 0

#5
I have asked my hosting company and they said that IP range was blocked due to recent DDOS attack to the server. They have lifted the block, and my friend confirmed she can now open http and get redirected to https , as what it should be. Thanks all for the help.
 
 
Forum Jump:

Users browsing this thread: 1 Guest(s)